内核恐慌

51. 挖坑 DNS

内核恐慌

Show Notes

本期开场聊了中兴通讯被美国制裁的事情,然后切入正题聊 DNS 的各种坑。

相关链接

Wassenaar Arrangment

Via’s Chinese Joint Venture Aims For Competitive Home-Grown X86 SOCs By 2019

如何看待兆芯?

APNIC Labs enters into a Research Agreement with Cloudflare

Reliable DNS Forgery in 2008: Kaminsky’s Discovery

Understanding Kaminsky’s DNS Bug

RFC7871: Client Subnet in DNS Queries

Cloudflare: How DNSSEC Works

DNSCrypt

RFC7858: DNS over TLS

IETF draft DNS over HTTPS

RFC7413: TCP Fast Open

RFC7918: TLS False Start

A Question of DNS Protocols

1.1.1.1

8.8.8.8

114DNS (114.114.114.114, 114.114.115.115)

DNSPod (119.29.29.29)

Alidns (223.5.5.5, 223.6.6.6)

BaiduDNS (180.76.76.76)

More from 内核恐慌

Jul 7, 2025

庆祝Apple 播客20周年的节目,实在太长了拆成两期播出。本期前半截两位「中文播客活化石™」回顾了自己从接触播客到制作播客的历程;后半截讨论如何挑选作为生产力工具(而不是玩游戏用)的桌面显示器。

Mar 8, 2025

编程经历了人力(纸带打孔)驱动和畜力(aka IT牛马)驱动时代,即将进入内燃机(AI)驱动的时代。你准备好了吗?

Mar 18, 2024

本期重拾程序员访谈系列,请来德国亚琛工大的陈龙博士,从滑雪开始,聊到计算机视觉(Computer Vision)的研究方向和应用场景、神经网络的可解释性、以及在德国读博的心路历程和回国的计划。

Dec 5, 2023

我们和「脑放电波」播客的串台节目,涉及的话题包括 NAS、充电宝、机械键盘、RGB「光污染」、VR、创客文化、以及 STEM 教育。

Dec 4, 2023

从吴涛疫情后第一次回国参加线下活动以及短暂的失业经历聊起,我们谈到以 ChatGPT 为代表的生成式人工智能是否预示着以编程为代表的人类智力劳动的终结,以及强人工智能出现后人类不再需要从事任何劳动以获取收入的情况下,生命的意义与信仰问题。

See all episodes →