Show Notes
episode 17 — Early Web History and Interlisp with Larry Masinter.
We sit down with internet pioneer and longtime IETF contributor Larry Masinter to revisit the origins of many technologies developers use every day. From his early days at Xerox PARC to co-authoring foundational RFCs on HTTP, URIs, and more, Larry shares first-hand stories that connect the early web to the world we build in now. The conversation also explores his current passion project: reviving the Interlisp environment as a living historical system.
Learn more:
https://larrymasinter.net/ — Official website from Larry Masinter https://www.rfc-editor.org/rfc/rfc2616 — RFC 2616 – HTTP/1.1 Specification https://www.rfc-editor.org/rfc/rfc3986 — RFC 3986 – URI Generic Syntax https://www.rfc-editor.org/rfc/rfc2324 — RFC 2324 – Hypertext Coffee Pot Control Protocol https://www.rfc-editor.org/rfc/rfc2732 — RFC 2732 – Literal IPv6 Addresses in URLs https://datatracker.ietf.org/doc/html/draft-masinter-dated-uri — Draft: the 'tdb' and 'duri' URI schemes, based on dated URIs https://interlisp.org — The Interlisp Revival Project
Rama
If you like this podcast you might also like our modular network framework in Rust: https://ramaproxy.org
Chapters
00:00 Intro 00:34 Introduction to Larry Masinter 05:32 The Intellectual Environment at Xerox PARC 06:49 The Interlisp Project and Its Impact 10:05 Transitioning to Document Servers and HTTP 12:02 Resources, Gopher and the Early Web 15:45 Why did HTTP succeed where Gopher faded away 20:56 Larry's Involvement in Web Standards and Protocols 25:11 Reviving Interlisp post-pandemic 27:13 interlisp.org, 5 years later 32:57 The Tradition of April 1st RFCs 33:51 Invention of Hypertext Coffee Pot Control Protocol (1998) 37:04 The Invention of HTCPCP 40:55 Exploring URI Schemes 47:58 Form-Based File Upload 49:12 The Politics of Web Standards 01:05:12 The Evolution of Web Protocols 01:05:53 Developing in the Interlisp Environment 01:14:03 Goals of the Interlisp Revival Project 01:23:39 Collaborations and Future Aspirations 01:25:09 Outro
Netstack.FM
More information: https://netstack.fm/#episode-17 Join our Discord: https://discord.gg/29EetaSYCD Reach out to us: [email protected]
Music for this episode was composed by Dj Mailbox. Listen to his music at https://on.soundcloud.com/4MRyPSNj8FZoVGpytj
More from netstack.fm
Episode 38: Building and testing network stacks with Rama. In this Protocol Shorts episode of Netstack.fm, Glen talks with Brecht Stamper about Rama, the modular Rust framework for building clients, servers, proxies, and other network systems. Brecht shares how he came to understand Rama’s core idea that everything is a service, and why that simple input to output contract makes it easier to compose complex stacks without constantly inventing new traits or glue code.
episode 37: dial9: from black box to insight in Tokio.
Remaster of: Season 1 · Episode 3 — OpenTelemetry, eBPF, and Metoro
Remaster of: Season 1 · Episode 5 — Tokio with Carle Lerche